summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c4ba014724f1..66b34b48d5c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,27 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=redshift-wlr-gamma-control
-pkgver=1.12+25+geecbfed
+pkgver=1.12+r25+geecbfed
_commit=eecbfedac48f827e96ad5e151de8f41f6cd3af66
-pkgrel=2
-pkgdesc="Redshift fork supporting color temperature adjustment with wlroots"
+pkgrel=1
+pkgdesc='Redshift fork supporting color temperature adjustment with wlroots'
arch=(i686 x86_64)
url=https://github.com/minus7/redshift/tree/wayland
license=(GPL3)
-provides=(redshift)
-conflicts=(redshift)
-depends=(geoclue2 libdrm libxcb libxxf86vm)
+depends=(glib2 hicolor-icon-theme libdrm libxxf86vm python wayland)
+makedepends=(git intltool)
optdepends=('python-gobject: for redshift-gtk'
- 'python-xdg: for redshift-gtk'
'gtk3: for redshift-gtk'
- 'sway: Wayland environment with wlr-gamma-control protocol')
-makedepends=(git intltool python wayland)
+ 'geoclue: for geolocation support'
+ 'sway: Wayland environment using the wlr-gamma-control protocol')
+provides=(redshift)
+conflicts=(redshift)
source=(git+${url/\/tree*/}#commit=$_commit)
sha512sums=('SKIP')
pkgver() {
cd redshift
- git describe --long --tags | sed 's/v//;s/-/+/g'
+ git describe --long --tags | sed 's#v##;s#-#+#g;s#+#+r#'
}
build() {
@@ -41,4 +41,5 @@ build() {
package() {
cd redshift
make DESTDIR="$pkgdir" install
+ install -Dm 644 COPYING -t "$pkgdir"/usr/share/licenses/redshift
}