summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ddd48721f844
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Albert Berger < nbdspcl at gmail dot com>
+pkgname=regd
+pkgver=0.4
+pkgrel=1
+pkgdesc="Registry daemon, information cache and secure credential storage."
+arch=('any')
+url="https://github.com/nbdsp/regd"
+license=('GPL')
+groups=()
+depends=('python3')
+optdepends=('')
+makedepends=('')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+replaces=()
+backup=()
+options=()
+install=
+source=("${pkgname}::$url#tag=v0.4")
+noextract=()
+md5sums=('SKIP')
+
+
+package() {
+ cd "${pkgname}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 "data/conf.${pkgname}" "$pkgdir/etc/${pkgname}/conf.${pkgname}"
+ install -Dm644 "${pkgname}.1" "$pkgdir/usr/share/man/man1/${pkgname}.1"
+}