summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 3 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a4133c4d6d62..ad7340af04ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=reicast-git
-pkgver=r1078.0783875
+pkgver=r1200.a9fc0f5
pkgrel=1
pkgdesc="A multiplatform Sega Dreamcast emulator (development version)"
arch=('i686' 'x86_64')
@@ -10,8 +10,8 @@ license=('GPL2' 'BSD' 'MIT')
conflicts=('reicast')
provides=('reicast')
makedepends=('git')
-depends=('lib32-libgl' 'lib32-alsa-lib')
-[ "$CARCH" == "i686" ] && depends=('libgl' 'alsa-lib')
+depends_x86_64=('lib32-libgl' 'lib32-alsa-lib')
+depends_i686=('libgl' 'alsa-lib')
source=(reicast::"git+https://github.com/reicast/reicast-emulator.git")
md5sums=('SKIP')
@@ -20,12 +20,6 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd reicast/shell/lin86
- # uncomment the following line to build with GLES instead of GL 3.1
- #sed '/-DGLES/s/^#//;/-lGL /s/.*/# &/;/-lEGL/s/^#//' -i Makefile
-}
-
build () {
make -C reicast/shell/lin86
}