summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 19e4bea8b777..aaacdc63d349 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,33 +3,34 @@
# flashback_data_files.7z if from http://gtamp.com/PSP/reminiscencepsp.php
pkgname=reminiscence
-pkgver=0.2.1
+pkgver=0.3.2
pkgrel=1
pkgdesc="A rewrite of the flashback engine"
arch=('i686' 'x86_64')
url="http://cyxdown.free.fr/reminiscence/"
license=('GPL')
-depends=('sdl')
+depends=('sdl' 'libmodplug' 'zlib' 'bash')
makedepends=('p7zip')
source=(http://cyxdown.free.fr/reminiscence/REminiscence-${pkgver}.tar.bz2
http://gtamp.com/PSP/flashback_data_files.7z
- fix-keys.diff
reminiscence.sh)
-md5sums=('59e7c5b3848c65f8eddb0e8c0e588221'
+md5sums=('35b891b82c2b1c8ce69dbda550d5de27'
'f994412ad4246c587896dab7d2eb9627'
- 'e470517e2933c09362681c620938d218'
'4ed0350e4b81e9ba305f90e157c75371')
+noextract=('flashback_data_files.7z')
build() {
cd "$srcdir/REminiscence-$pkgver"
- patch -p1 -i "$srcdir/fix-keys.diff"
+ make CXX=g++ CXXFLAGS="-Wall -MMD \$(SDL_CFLAGS) -DUSE_MODPLUG -DUSE_ZLIB -O"
+}
- make
+package() {
+ cd "$srcdir/REminiscence-$pkgver"
- install -d "$pkgdir/usr/bin"
- install -m755 rs "$pkgdir/usr/bin/reminiscence.bin"
- install -m755 "$srcdir/reminiscence.sh" "$pkgdir/usr/bin/reminiscence"
+ #install -d "$pkgdir/usr/bin"
+ install -Dm755 rs "$pkgdir/usr/bin/reminiscence.bin"
+ install -Dm755 "$srcdir/reminiscence.sh" "$pkgdir/usr/bin/reminiscence"
msg2 "Extracting flashback_data_files.7z with p7zip"
install -m755 -d "$pkgdir/usr/share/reminiscence"