summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 18 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8407378ec98f..79b82535e0ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,35 @@
-# Maintainer: Juston Li <juston.h.li@gmail.com>
+# Maintainer: Luca Weiss <luca (at) z3ntu (dot) xyz>
+# Contrubitor: Juston Li <juston.h.li@gmail.com>
# Contributor: Jerome Leclanche <jerome@leclan.ch>
_pkgname=repo
-pkgname=$_pkgname-git
-pkgver=1.12.26.r7.g5d0c3a6
+pkgname=repo-git
+pkgver=1.13.2.r0.g13f323b2
pkgrel=1
-pkgdesc="Tool built on top of git to help manage many git repositories. Part of the Android project."
-arch=("any")
+pkgdesc="The Multiple Git Repository Tool"
+arch=('any')
url="https://source.android.com/source/developing.html"
-license=("APACHE")
-depends=("git" "python2")
+license=('Apache')
+depends=('git' 'python2')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("$_pkgname::git+https://gerrit.googlesource.com/git-repo"
- "python2.patch")
-sha256sums=("SKIP"
- "bdb224e0e04060d6ec7e2fcc95bcf09ad46585e0ff65d914050192b60ce990d4")
-
+ "python2.patch")
+sha256sums=('SKIP'
+ 'bdb224e0e04060d6ec7e2fcc95bcf09ad46585e0ff65d914050192b60ce990d4')
pkgver() {
- cd "$srcdir/$_pkgname"
- git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/$_pkgname"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/$_pkgname"
- patch -p1 < "${srcdir}/python2.patch"
+ cd "$_pkgname"
+ patch -Np1 -i "$srcdir"/python2.patch
}
package() {
- cd "$srcdir/$_pkgname"
- install -D -m 755 repo "$pkgdir/usr/bin/repo"
- install -D -m 644 docs/manifest-format.txt "$pkgdir/usr/share/doc/repo/manifest-format.txt"
+ cd "$_pkgname"
+ install -Dm755 repo "$pkgdir"/usr/bin/repo
+ install -Dm644 docs/manifest-format.md "$pkgdir"/usr/share/doc/repo/manifest-format.md
}