summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bec89f460d64..68e340e08716 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,12 @@ pkgdesc="Run a process twice and check the output for reproducibility"
arch=('any')
license=('GPL2' 'GPL3')
url="https://salsa.debian.org/reproducible-builds/reprotest"
-depends=('python' 'python-rstr' 'diffoscope' 'fakeroot' 'python-distro')
-optdepends=('disorderfs' 'python-progressbar')
+depends=('python-setuptools' 'python' 'python-rstr' 'diffoscope' 'fakeroot' 'python-distro')
+optdepends=(
+ # to enable the shuffle-dirents option
+ 'disorderfs'
+ # to show a progress bar during diffoscope
+ 'python-progressbar')
source=(https://salsa.debian.org/reproducible-builds/reproducible-lfs/raw/master/releases/${pkgname}/${pkgname}_${pkgver}.tar.xz{,.asc})
sha512sums=('2f3f6c609c18f184b5c1eacd820f439e10432b2bc31f275838b297ce4b90e2657d1d900486412847b5b7fb7ec1c85eb67c3b8f68518d2da9bfb78a53b08bfccc'
'SKIP')
@@ -23,7 +27,6 @@ build() {
}
package() {
- depends=('python' 'python-setuptools')
cd "$srcdir/${pkgname}"
python setup.py install --root="$pkgdir" --optimize=1
}