summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 4 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cb8a38dc6aa4..22832cc786b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,19 @@
# Contributor: Shalygin Konstantin <k0ste@k0ste.ru>
pkgbase='requests-aws'
-pkgname=('python-requests-aws' 'python2-requests-aws')
+pkgname='python-requests-aws'
pkgver='0.1.8'
pkgrel='1'
pkgdesc='AWS authentication for Amazon S3 for the python requests module'
arch=('any')
url="https://github.com/tax/python-${pkgbase}"
-makedepends=('python' 'python-setuptools'
- 'python2' 'python2-setuptools')
+makedepends=('python' 'python-setuptools')
+depends=('python-requests')
license=('BSD')
source=("https://pypi.io/packages/source/${pkgbase:0:1}/${pkgbase}/${pkgbase}-${pkgver}.tar.gz")
sha256sums=('bd2e8386f09d94a84b9cad6e966b21f31493734336a8f47b9b535806949a771f')
-package_python-requests-aws() {
- depends=('python-requests')
-
+package() {
cd "${srcdir}/${pkgbase}-${pkgver}"
python setup.py install -O1 --root="${pkgdir}"
}
-
-package_python2-requests-aws() {
- depends=('python2-requests')
-
- cd "${srcdir}/${pkgbase}-${pkgver}"
- python2 setup.py install -O1 --root="${pkgdir}"
-}