summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ab5853efaa6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Florian Daniel <fd@noxa.de>
+# Contributor: Eldar Tsraev <elts@culab.org>
+# Contributor: Andreas Guth <andreas.guth@rwth-aachen.de>
+# Contributor: Alexander Neumann <alexander@bumpern.de>
+options=(!strip)
+pkgname=restic-git
+pkgver=r702.c143f8c
+pkgrel=1
+pkgdesc="restic is a program that does backups right."
+arch=('i686' 'x86_64')
+url="https://github.com/restic/restic"
+license=('BSD')
+depends=('glibc')
+makedepends=('git' 'go>=1.3')
+provides=('restic')
+conflicts=('restic')
+source=("${pkgname}::git+https://github.com/restic/restic")
+md5sums=('SKIP')
+
+importpath='github.com/restic/restic'
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)";
+}
+
+build() {
+ cd "$pkgname"
+ go run build.go
+}
+
+package() {
+ install -Dm755 "$pkgname/restic" "$pkgdir/usr/bin/restic"
+ install -Dm644 "$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$pkgname/README.md" "$pkgdir/usr/share/doc/$pkgname/README"
+}
+
+# vim:set ts=2 sw=2 et: