summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6ab5853efaa6..b6e4ae7c28dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Alexander Neumann <alexander@bumpern.de>
options=(!strip)
pkgname=restic-git
-pkgver=r702.c143f8c
+pkgver=v0.1.0.r172.g1f1b8e1
pkgrel=1
pkgdesc="restic is a program that does backups right."
arch=('i686' 'x86_64')
@@ -21,7 +21,7 @@ importpath='github.com/restic/restic'
pkgver() {
cd "$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)";
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {