summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8c2f3d59a0bd..3a140125bbf3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgname=retroarch
pkgname=retroarch-rbp4
-pkgver=1.9.0
+pkgver=1.9.7
pkgrel=1
pkgdesc='Reference frontend for the libretro API (Raspberry Pi 4)'
arch=(armv7h)
@@ -26,7 +26,6 @@ depends=(
libswresample.so
libswscale.so
libudev.so
- libusb-1.0.so
libxkbcommon
mbedtls
mesa
@@ -35,6 +34,7 @@ depends=(
)
makedepends=(
git
+ vulkan-headers
)
optdepends=(
'libretro-overlays: Collection of overlays'
@@ -44,7 +44,7 @@ optdepends=(
'retroarch-assets-xmb: XMB menu assets'
)
backup=(etc/retroarch.cfg)
-_tag=5e551dd92b79d8127e66939835ea3c2a140c4078
+_tag=8373ac67460cd0e092453bad6bb83e674b5af31a
source=(
git+https://github.com/libretro/RetroArch.git#tag=${_tag}
retroarch-config.patch
@@ -96,13 +96,13 @@ build() {
--disable-wayland \
--disable-x11 \
--disable-videocore \
- --disable-vulkan \
- --disable-vulkan_display \
--enable-kms \
--enable-opengles \
--enable-opengles3 \
--enable-opengl_core \
- --enable-plain_drm
+ --enable-plain_drm \
+ --enable-vulkan \
+ --enable-vulkan_display
make
make -C libretro-common/audio/dsp_filters
make -C gfx/video_filters