summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4cba7f53455a..c6625cfe3a97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,7 +28,7 @@ _nativ_dialogs='true'
_pkgname=retroshare
pkgname=${_pkgname}-git
-pkgver=v0.6.6.r8.g67c607cb3
+pkgver=v0.6.6.r49.gd1a166df5
pkgrel=1
pkgdesc="Serverless encrypted instant messenger with filesharing, chatgroups, e-mail."
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
@@ -42,8 +42,11 @@ optdepends=('tor: tor hidden node support'
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=("${_pkgname}::git+https://github.com/RetroShare/RetroShare.git")
-sha256sums=('SKIP')
+source=("${_pkgname}::git+https://github.com/RetroShare/RetroShare.git"
+ 'fix_create_directories.patch'
+)
+sha256sums=('SKIP'
+ '1019d25aa0f6d467fcd1e67c15acb5e11a44f97b328385b750b061decdcdf6a3')
# Add sql dependency
[[ "$_no_sqlcipher" == 'true' ]] && depends=(${depends[@]} 'sqlite') || depends=(${depends[@]} 'sqlcipher')
@@ -75,7 +78,6 @@ _optNativDialogs=''
if [[ "$_plugin_lua4rs" == 'true' ]] ; then
depends=(${depends[@]} 'lua')
source=(${source[@]} 'Lua4RS::git+https://github.com/RetroShare/Lua4RS.git')
- sha256sums=(${sha256sums[@]} 'SKIP')
fi
pkgver() {
@@ -83,6 +85,12 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+
+ patch -p1 --ignore-whitespace -i "${srcdir}"/fix_create_directories.patch
+}
+
build() {
cd "${srcdir}/${_pkgname}"