summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD78
1 files changed, 25 insertions, 53 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 29e810f18d9c..320482ec62c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,60 +1,32 @@
pkgname=revc-git
-pkgver=1
+pkgver=1.0+r870.a16fcd8d
pkgrel=1
-pkgdesc="Grand Theft Auto Vice City reverse engineered"
-arch=('x86_64')
-depends=('openal' 'glew' 'glfw' 'libsndfile' 'mpg123')
-makedepends=('git' 'cmake' 'premake')
-provides=('revc')
-license=('none')
-
-install=$pkgname.install
+pkgdesc="Grand Theft Auto: Vice City reverse engineered"
+arch=(x86_64 aarch64)
+url=https://github.com/td512/re3/tree/miami
+license=(custom:none)
+depends=(librw-git openal mpg123)
+makedepends=(cmake)
+install=revc.install
source=(
- 'git+https://github.com/erorcun/re3.git#branch=miami'
- 'git+https://github.com/aap/librw.git'
- 'git+https://github.com/xiph/ogg.git'
- 'git+https://github.com/xiph/opus.git'
- 'git+https://github.com/xiph/opusfile.git'
- 'launch.sh'
- 'GTAVC.desktop')
+ git+https://github.com/td512/re3.git#branch=miami
+ reVC.desktop)
md5sums=(
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- '9eb2aff2687f8cc735ea93e0460f07e0'
- '2991b7cf6751274bfdccc7b6f0272129')
-
-pkgver() {
- cd "$srcdir/re3"
- printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ SKIP
+ a7cd29fced93db056a84486f166f1ecc)
+pkgver(){
+ cd re3
+ git describe --tags|sed 's/.*_//;s/-\(.*\)-g/+r\1./'
}
-
-prepare() {
- cd "$srcdir/re3"
-
- git submodule init
- for submod in librw ogg opus opusfile
- do
- git config "submodule.vendor/$submod.url" "../$submod"
- done
- git submodule update
+build(){
+ cd re3
+ cmake -DREVC_VENDORED_LIBRW= .
+ make
}
-
-build() {
- cd "$srcdir/re3"
-
- premake5 --with-librw gmake2
- cd "build"
- "./../printHash.sh" "./../src/extras/GitSHA1.cpp"
- make O=. config=release_linux-amd64-librw_gl3_glfw-oal
-}
-
-package() {
- cd "$srcdir/re3/bin/linux-amd64-librw_gl3_glfw-oal/Release"
- install -d $pkgdir/opt/reVC
- install -m755 reVC $pkgdir/opt/reVC/
- install -m755 $srcdir/launch.sh $pkgdir/opt/reVC/
- install -D -m644 $srcdir/GTAVC.desktop $pkgdir/usr/share/applications/GTAVC.desktop
+package(){
+ cd re3
+ install src/reVC -Dt "$pkgdir"/usr/bin
+ install -D {res/images/logo,"$pkgdir"/usr/share/pixmaps/reVC}.svg
+ install ../reVC.desktop -Dt "$pkgdir"/usr/share/applications
+ cp -r gamefiles "$pkgdir"/usr/share/reVC
}