summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c01afa304117
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jefferson Gonzalez <jgmdev@gmail.com>
+
+pkgname=rgb2cmyk
+pkgver=1.0
+pkgrel=1
+pkgdesc="GUI to facilitate conversion of an image from RGB to CMYK colorspace"
+arch=('i686' 'x86_64' 'aarch64')
+url="https://github.com/jgmdev/rgb2cmyk"
+license=('GPL')
+depends=('wxgtk3' 'colord' 'imagemagick')
+makedepends=('ninja' 'meson')
+source=("https://github.com/jgmdev/rgb2cmyk/archive/refs/tags/v${pkgver}.tar.gz")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ meson setup build --native-file nativefile.ini --prefix /usr
+ ninja -j$(nproc) -C build
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ DESTDIR="${pkgdir}" ninja -C build install
+}