summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 423b9faff7ba..48efd06f7eac 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,13 @@
# Contributor: der_fenix <derfenix@gmail.com>
pkgname=rhvoice-git
-pkgver=1.2.3.r37.2dc35bc
+pkgver=1.2.3.r59.c699a39
pkgrel=1
pkgdesc="Free and open source speech synthesizer for Russian and other languages. (development version)"
arch=('x86_64')
-url="https://github.com/Olga-Yakovleva/RHVoice"
-license=('GPL3')
+url="https://github.com/RHVoice/RHVoice"
+license=('GPL3' 'custom' 'custom:by-nc-nd-4.0' 'custom:by-nc-sa-4.0'
+ 'custom:by-sa-4.0')
depends=('libpulse')
makedepends=('git' 'scons')
optdepends=('rhvoice-dictionary-git: extended russian dictionary'
@@ -18,7 +19,7 @@ optdepends=('rhvoice-dictionary-git: extended russian dictionary'
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
backup=('etc/RHVoice/RHVoice.conf')
-source=(${pkgname%-git}::'git+https://github.com/Olga-Yakovleva/RHVoice.git')
+source=(${pkgname%-git}::'git+https://github.com/RHVoice/RHVoice.git')
md5sums=('SKIP')
pkgver() {
@@ -34,8 +35,12 @@ build() {
package() {
cd "$srcdir/${pkgname%-git}"
- mkdir -p "${pkgdir}/usr/lib/speech-dispatcher-modules"
+ install -d "${pkgdir}/usr/lib/speech-dispatcher-modules"
scons install DESTDIR="${pkgdir}" prefix="/usr" sysconfdir="/etc" \
CPPFLAGS="$CPPFLAGS" CCFLAGS="$CFLAGS" LINKFLAGS="$LDFLAGS"
ln -s "/usr/bin/sd_rhvoice" "${pkgdir}/usr/lib/speech-dispatcher-modules/sd_rhvoice"
+ install -Dm0644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm0644 licenses/by-nc-nd-4.0.txt "${pkgdir}/usr/share/licenses/${pkgname}/by-nc-nd-4.0"
+ install -Dm0644 licenses/by-nc-sa-4.0.txt "${pkgdir}/usr/share/licenses/${pkgname}/by-nc-sa-4.0"
+ install -Dm0644 licenses/by-sa-4.0.txt "${pkgdir}/usr/share/licenses/${pkgname}/by-sa-4.0"
}