summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 6 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 075d33a7970d..e9b996170405 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Old maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=rhythmbox-plugin-alternative-toolbar-git
-pkgver=0.r210.fc71d3c
-pkgrel=2
+pkgver=0.r251.1427c62
+pkgrel=1
pkgdesc='Replace the Rhythmbox large toolbar with a Client-Side Decorated or Compact Toolbar which can be hidden'
url='https://github.com/fossfreedom/alternative-toolbar'
arch=('any')
@@ -24,18 +24,8 @@ pkgver() {
package() {
cd rhythmbox-plugin-alternative-toolbar
-
- install -dm 755 "${pkgdir}"/usr/{lib,share}/rhythmbox/plugins/alternative-toolbar
- install -dm 755 "${pkgdir}"/usr/share/locale
- cp -dr --no-preserve='ownership' alternative-toolbar.plugin *.py "${pkgdir}"/usr/lib/rhythmbox/plugins/alternative-toolbar/
- python -m compileall "${pkgdir}"/usr/lib/rhythmbox/plugins/alternative-toolbar
- python -O -m compileall "${pkgdir}"/usr/lib/rhythmbox/plugins/alternative-toolbar
- cp -dr --no-preserve='ownership' img ui "${pkgdir}"/usr/share/rhythmbox/plugins/alternative-toolbar/
- install -dm 755 "${pkgdir}"/usr/share/glib-2.0/schemas
- install -m 644 schema/org.gnome.rhythmbox.plugins.alternative_toolbar.gschema.xml "${pkgdir}"/usr/share/glib-2.0/schemas/
-
- cd po
- ./install_all.sh "${pkgdir}"/usr/share/locale/
+ ./autogen.sh --prefix=${pkgdir}/usr
+ make
+ make install
+ rm ${pkgdir}/usr/share/glib-2.0/schemas/gschemas.compiled
}
-
-# vim: ts=2 sw=2 et: