summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 20 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b5829c45c75c..cd67f0e0dd92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,36 @@
-# Maintainer: Coelacanthus <liuhongwu2003@outlook.com>
+# Maintainer: Coelacanthus <coelacanthus@outlook.com>
pkgname=rime-liangfen
-pkgver=0.0.0.20200821
-_commit=a67ea69d45c2785048ad05b1639d9f01ad5a01f0
+pkgver=4.0
+#_commit=a67ea69d45c2785048ad05b1639d9f01ad5a01f0
pkgrel=1
-pkgdesc="unapproved fork of LiangFen by Sim CheonHyeong"
+pkgdesc="LiangFen by Sim CheonHyeong"
arch=('any')
-url="https://github.com/szc126/rime-liangfen"
+url="http://cheonhyeong.com/Simplified/download.html"
license=('custom')
# dependency for reverse lookup
depends=('rime-prelude')
makedepends=('librime')
-source=("https://github.com/szc126/rime-liangfen/archive/$_commit/rime-liangfen-$_commit.tar.gz")
-sha512sums=('6590ada15b096fdcd6d02bffe1fe46112dbaa873388130d86d08914ede53f59487b4fc77ed10f55b559c79e50141d41dad6c1f4b42831d04e46c363082e568fa')
+source=("http://cheonhyeong.com/File/ZHLF_rime_$pkgver.7z")
+b2sums=('49f36577774a44f36c1946aed06a6dd00e1f9b3a9186d182bdda338fafdb222635ba76cc68107ecbd778870b719ee955c5abffa6a582aa05121fb128a3fad7fd')
prepare() {
- cd $pkgname-$_commit
- # Link essentials
- for _f in $(pacman -Qql rime-prelude | grep -v "/$"); do ln -sf $_f; done
+ cd $srcdir
+ # Link essentials
+ for _f in $(pacman -Qql rime-prelude | grep -v "/$"); do ln -sf $_f; done
}
-build(){
- cd $pkgname-$_commit
- for _s in $(ls *.schema.yaml); do rime_deployer --compile $_s; done
+build() {
+ cd $srcdir
+ for _s in $(ls *.schema.yaml); do rime_deployer --compile $_s; done
}
package() {
- cd $pkgname-$_commit
- find . -type l -delete
- rm build/*.txt
- install -Dm644 *.yaml -t "$pkgdir"/usr/share/rime-data/
- install -Dm644 build/* -t "$pkgdir"/usr/share/rime-data/build/
-
- #install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/
+ cd $srcdir
+ find . -type l -delete
+ rm build/*.txt
+ install -Dm644 *.yaml -t "$pkgdir"/usr/share/rime-data/
+ install -Dm644 build/* -t "$pkgdir"/usr/share/rime-data/build/
+
+ #install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/
}