summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..359c3f504809
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Sean Snell <ssnell at cmhsol dot com>
+
+pkgname=rmmagent
+pkgver=1.0.2.1
+pkgrel=4
+pkgdesc='Remote Monitoring Agent for GFI Languard Dashboard'
+arch=('i686' 'x86_64')
+url='http://languard.gfi.com/'
+license=('custom')
+options=('!strip')
+provides=('rmmagent')
+depends_x86_64=(
+ 'ethtool'
+ 'smartmontools'
+ 'gcc-libs'
+ 'glibc'
+ 'openssl'
+ 'unzip')
+
+depends_i686=(
+ 'ethtool'
+ 'smartmontools'
+ 'gcc-libs'
+ 'glibc'
+ 'openssl'
+ 'unzip')
+
+install=.INSTALL
+source_x86_64=("http://repos.systemmonitor.us/rmmagent/Debian_7.0/amd64/rmmagent_1.0.2-1_amd64.deb")
+source_i686=("http://repos.systemmonitor.us/rmmagent/Debian_7.0/i386/rmmagent_1.0.2-1_i386.deb")
+
+md5sums_x86_64=('ed1afc694402e151ed72241600c10200')
+md5sums_i686=('870236044d12b7aaa236fb4475b3d3b4')
+
+prepare() {
+ tar -xf data.tar.gz
+ tar -xf control.tar.gz
+ mv usr/local/lib/ usr/lib
+ mv usr/local/rmmagent usr/rmmagent
+}
+
+package() {
+ # Install
+ cp -dr --no-preserve=ownership {etc,usr} "${pkgdir}"/
+}