summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 010aba1c16d2..d0d75ab053e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=('roccat-tools-full')
_pkgbase=roccat-tools
pkgver=3.6.1
-pkgrel=2
+pkgrel=3
pkgdesc='Userland applications to configure and make extended use of ROCCAT devices'
arch=('i686' 'x86_64')
url='http://roccat.sourceforge.net'
@@ -19,22 +19,21 @@ optdepends=('kmod-roccat: Adds support for the old kone device.'
'roccat-dkms: Adds support for the old kone device with dynamic rebuild.')
conflicts=('roccat-tools-common')
replaces=('roccat-tools-common')
-source=("http://downloads.sourceforge.net/project/roccat/roccat-tools/roccat-tools-$pkgver.tar.bz2"
- 'udev-compilation-error-fix.patch')
+source=("http://downloads.sourceforge.net/project/roccat/roccat-tools/roccat-tools-$pkgver.tar.bz2")
install=roccat-tools.install
-sha1sums=('3eab9a07dd586eb6c1648b060f36b4592525416b'
- 'd31ad74bf91628f21415a631ec0f57b707266d0f')
+sha1sums=('3eab9a07dd586eb6c1648b060f36b4592525416b')
build() {
cd "$srcdir/$_pkgbase-$pkgver"
- patch -p1 -i ../udev-compilation-error-fix.patch
cmake . -DCMAKE_INSTALL_PREFIX=/usr -DUDEVDIR=/usr/lib/udev/rules.d -DWITHOUT_PYTHON=TRUE
+
make
}
package() {
cd "$srcdir/$_pkgbase-$pkgver"
+
make DESTDIR="$pkgdir/" install
}