summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c4a5d7e7146a..50ff68d9a3a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony <tony@criticalstack.com>
pkgname=rocksdb-static
-pkgver=6.0.2
+pkgver=6.2.2
pkgrel=1
pkgdesc='Embedded key-value store for fast storage (static library)'
arch=(i686 x86_64)
@@ -9,8 +9,10 @@ url='http://rocksdb.org'
license=('Apache')
depends=('gperftools' 'zlib' 'bzip2' 'lz4' 'snappy' 'gcc-libs')
checkdepends=('python2')
-source=("https://github.com/facebook/rocksdb/archive/v${pkgver}.tar.gz")
-sha256sums=('89e0832f1fb00ac240a9438d4bbdae37dd3e52f7c15c3f646dc26887da16f342')
+source=("https://github.com/facebook/rocksdb/archive/v${pkgver}.tar.gz"
+ "fix-compile-warnings-treated-as-errors-for-gcc9.patch")
+sha256sums=('3e7365cb2a35982e95e5e5dd0b3352dc78573193dafca02788572318c38483fb'
+ '775b1099346843f0598168aff8d6621857012155234a2d50f87ed4bcad363c2d')
prepare() {
cd "${srcdir}/rocksdb-${pkgver}"
@@ -19,6 +21,8 @@ prepare() {
if [ "$CARCH" == "armv6h" ]; then
sed -e 's/-momit-leaf-frame-pointer//' -i Makefile
fi
+
+ patch -F3 -p1 -i "${srcdir}/fix-compile-warnings-treated-as-errors-for-gcc9.patch"
}
build() {