summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3747b4c15f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+pkgname=rocm-smi-lib64
+pkgver=3.5.0
+pkgrel=1
+pkgdesc="ROCm SMI LIB"
+arch=('x86_64')
+url="https://github.com/RadeonOpenCompute/rocm_smi_lib"
+license=('custom:NCSAOSL')
+depends=()
+makedepends=('cmake')
+options=(!staticlibs strip)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/RadeonOpenCompute/rocm_smi_lib/archive/rocm-$pkgver.tar.gz")
+sha256sums=('a5d2ec3570d018b60524f0e589c4917f03d26578443f94bde27a170c7bb21e6e')
+
+build() {
+ mkdir -p "$srcdir/build"
+ cd "$srcdir/build"
+
+ cmake -DCMAKE_INSTALL_PREFIX=/opt/rocm \
+ "$srcdir/rocm_smi_lib-rocm-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/build"
+ make DESTDIR="$pkgdir" install
+}