summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4f40de793438..cc1a02f91860 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Torsten Keßler <t dot kessler at posteo dot de>
# Contributor: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=rocsparse
-pkgver=4.2.0
+pkgver=4.3.0
pkgrel=1
pkgdesc='BLAS for sparse computation on top of ROCm'
arch=('x86_64')
@@ -11,15 +11,19 @@ depends=('hip-rocclr' 'rocprim')
makedepends=('cmake' 'git' 'gcc-fortran')
_git='https://github.com/ROCmSoftwarePlatform/rocSPARSE'
source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
-sha256sums=('8a86ed49d278e234c82e406a1430dc28f50d416f8f1065cf5bdf25cc5721129c')
+sha256sums=('1a8109bdc8863b3acfe991449360c9361cae7cabdbe753c553bc57872cd0ad5e')
_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
build() {
# -fcf-protection is not supported by HIP, see
- # https://github.com/ROCm-Developer-Tools/HIP/blob/rocm-4.2.x/docs/markdown/clang_options.md
+ # https://github.com/ROCm-Developer-Tools/HIP/blob/rocm-4.3.x/docs/markdown/clang_options.md
+
+ # With version 3.21, HIP support was added to CMake that breaks the current scripts, see
+ # https://github.com/ROCmSoftwarePlatform/rocRAND/issues/198#issuecomment-893573440
CXX=/opt/rocm/bin/hipcc \
CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \
cmake -Wno-dev -S "$_dirname" \
+ -D__skip_rocmclang=ON \
-DCMAKE_INSTALL_PREFIX=/opt/rocm \
-Drocprim_DIR=/opt/rocm/rocprim/rocprim/lib/cmake/rocprim \
-DBUILD_CLIENTS_SAMPLES=OFF