summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5af5e92a1f29..4f40de793438 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Torsten Keßler <t dot kessler at posteo dot de>
# Contributor: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=rocsparse
-pkgver=4.1.0
-pkgrel=2
+pkgver=4.2.0
+pkgrel=1
pkgdesc='BLAS for sparse computation on top of ROCm'
arch=('x86_64')
url='https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#rocsparse'
@@ -11,11 +11,14 @@ depends=('hip-rocclr' 'rocprim')
makedepends=('cmake' 'git' 'gcc-fortran')
_git='https://github.com/ROCmSoftwarePlatform/rocSPARSE'
source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
-sha256sums=('7514968ed2342dc274acce8b269c128a6aa96cce769a37fd3880b5269c2ed17f')
+sha256sums=('8a86ed49d278e234c82e406a1430dc28f50d416f8f1065cf5bdf25cc5721129c')
_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
build() {
+ # -fcf-protection is not supported by HIP, see
+ # https://github.com/ROCm-Developer-Tools/HIP/blob/rocm-4.2.x/docs/markdown/clang_options.md
CXX=/opt/rocm/bin/hipcc \
+ CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \
cmake -Wno-dev -S "$_dirname" \
-DCMAKE_INSTALL_PREFIX=/opt/rocm \
-Drocprim_DIR=/opt/rocm/rocprim/rocprim/lib/cmake/rocprim \