summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1102ea8ab8d3..3ef8c39b1b76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Torsten Keßler <t dot kessler at posteo dot de>
# Contributor: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=rocsparse
-pkgver=4.5.0
+pkgver=4.5.2
pkgrel=1
pkgdesc='BLAS for sparse computation on top of ROCm'
arch=('x86_64')
@@ -11,19 +11,16 @@ depends=('hip' 'rocprim')
makedepends=('cmake' 'git' 'gcc-fortran')
_git='https://github.com/ROCmSoftwarePlatform/rocSPARSE'
source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
-sha256sums=('b120e9e17e7e141caee4c8c4288c9d1902bad0cec2ea76458d3ba11343376938')
+sha256sums=('e37af2cd097e239a55a278df534183b5591ef4d985fe1a268a229bd11ada6599')
_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
build() {
# -fcf-protection is not supported by HIP, see
# https://github.com/ROCm-Developer-Tools/HIP/blob/rocm-4.5.x/docs/markdown/clang_options.md
- # With version 3.21, HIP support was added to CMake that breaks the current scripts, see
- # https://github.com/ROCmSoftwarePlatform/rocRAND/issues/198#issuecomment-893573440
CXX=/opt/rocm/bin/hipcc \
CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \
cmake -Wno-dev -S "$_dirname" \
- -D__skip_rocmclang=ON \
-DCMAKE_INSTALL_PREFIX=/opt/rocm \
-Drocprim_DIR=/opt/rocm/rocprim/rocprim/lib/cmake/rocprim \
-DBUILD_CLIENTS_SAMPLES=OFF