summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 744b8e4cf054..c16bd4a0f01a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,33 @@
# Maintainer: Romain GERARD <erebe@erebe.eu>
pkgname=rofi-greenclip
-pkgver=2.1
+pkgver=3.0
epoch=0
pkgrel=0
-pkgdesc="Clipboard manager to use with rofi"
+pkgdesc="Clipboard manager to use with rofi - Image support and blacklist"
arch=('x86_64')
url="https://github.com/erebe/greenclip"
license=('GPL')
groups=()
+changelog=changelog
depends=('rofi')
makedepends=()
checkdepends=()
optdepends=()
provides=("greenclip")
-conflicts=("greenclip")
-replaces=("greenclip")
+conflicts=("rofi-greenclip-beta")
+replaces=("rofi-greenclip-beta")
backup=()
options=('!strip')
install=
-changelog=changelog
-source=("https://github.com/erebe/greenclip/releases/download/2.1/greenclip")
+changelog=
+source=("https://github.com/erebe/greenclip/releases/download/3.0/greenclip")
noextract=()
-sha256sums=("9964a6520f3ec6c935e3f6ef4b4b6235d79aab38060305673a66a5c71e7c9e57")
+sha256sums=("a56cbba8e60e972e9db20757554db344de912ff9e7cd72e76d542796b9fa43ed")
package() {
+ kill -9 $(pidof greenclip) || test 1
+ rm -rf ~/.config/greenclip.cfg ~/.cache/greenclip.*
install -Dm 755 greenclip "$pkgdir/usr/bin/greenclip"
}