summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..284bed3d1f15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Rasmus Steinke <rasi@xssn.at>
+
+pkgname=rofi-top-git
+_gitname=rofi-top
+pkgver=r19.e5abb43
+pkgrel=1
+pkgdesc="A plugin for rofi that emulates top behaviour."
+arch=('i686' 'x86_64')
+url="https://gitcrate.org/qtools/rofi-top"
+license=('MIT')
+depends=(rofi-top libgtop)
+options=('!libtool')
+makedepends=('git')
+provides=('rofi-top')
+source=("git+https://gitcrate.org/qtools/rofi-top.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/$_gitname"
+ autoreconf --install
+
+ # Default compiler = clang, which can be a problem if using hardening-wrapper
+ CC=gcc ./configure --prefix=/usr
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ make install install-man DESTDIR="$pkgdir"
+}