summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87fa0a520321
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Noa Himesaka <himesaka AT noa DOT codes>
+pkgname=roon-tui
+pkgver=0.0.7
+pkgrel=1
+pkgdesc="A Roon Remote for the terminal"
+arch=('x86_64')
+license=('MIT')
+makedepends=('git' 'cargo')
+source=("git+https://github.com/TheAppgineer/roon-tui.git#tag=$pkgver")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$pkgname"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "$pkgname"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+package() {
+ # Install binary
+ install -Dm755 "$pkgname/target/release/roon-tui" "$pkgdir/usr/bin/roon-tui"
+}