summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD69
1 files changed, 69 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..229f5393397c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,69 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Implement the ROS middleware interface using PrismTech OpenSplice static code generation in C++."
+url='http://www.ros.org/'
+
+pkgname='ros-ardent-rmw-opensplice-cpp'
+pkgver='0.4.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('Apache License 2.0')
+
+ros_makedepends=(ros-ardent-rosidl-generator-cpp
+ ros-ardent-rosidl-typesupport-opensplice-cpp
+ ros-ardent-rosidl-typesupport-opensplice-c
+ ros-ardent-rosidl-generator-c
+ ros-ardent-opensplice-cmake-module
+ ros-ardent-ament-cmake
+ ros-ardent-rcutils
+ ros-ardent-rosidl-generator-dds-idl
+ ros-ardent-rosidl-cmake)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ opensplice)
+
+ros_depends=(ros-ardent-rmw)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/ardent/rmw_opensplice_cpp/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros2-gbp/rmw_opensplice-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="rmw_opensplice-release-release-ardent-rmw_opensplice_cpp-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros2-gbp/rmw_opensplice-release/archive/release/ardent/rmw_opensplice_cpp/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('1094c627942f57f017a186e33de635f6e2cdb998f7deaeebfeb3b892287ef6c9')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/ardent/setup.bash ] && source /opt/ros/ardent/setup.bash
+
+ # Create build directory
+ [ -d "${srcdir}/build" ] || mkdir "${srcdir}/build"
+ cd "${srcdir}/build"
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 "${srcdir}/${_dir}"
+
+ # Build project
+ cmake "${srcdir}/${_dir}" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/ardent \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.5m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.5m.so \
+ -DPYTHON_BASENAME=.cpython-35m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+ -DCATKIN_ENABLE_TESTING=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}