summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 62c7acb38869..e368099b18f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,17 @@ pkgdesc="ROS - C++ implementation of bond, a mechanism for checking when another
url='http://www.ros.org/wiki/bondcpp'
pkgname='ros-indigo-bondcpp'
-pkgver='1.7.14'
-_pkgver_patch=1
+pkgver='1.7.16'
+_pkgver_patch=0
arch=('any')
-pkgrel=3
+pkgrel=1
license=('BSD')
ros_makedepends=(ros-indigo-bond
- ros-indigo-smclib
+ ros-indigo-cmake-modules
+ ros-indigo-catkin
ros-indigo-roscpp
- ros-indigo-catkin)
+ ros-indigo-smclib)
makedepends=('cmake' 'git' 'ros-build-tools'
${ros_makedepends[@]}
util-linux
@@ -51,6 +52,7 @@ build() {
-DPYTHON_EXECUTABLE=/usr/bin/python2 \
-DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
-DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}