summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 770c5f3e7a72..651fd301cfd9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgdesc="ROS - qt_gui_cpp provides the foundation for C++-bindings for qt_gui an
url='http://ros.org/wiki/qt_gui_cpp'
pkgname='ros-indigo-qt-gui-cpp'
-pkgver='0.2.30'
+pkgver='0.2.32'
_pkgver_patch=0
arch=('any')
pkgrel=1
@@ -32,7 +32,7 @@ depends=(${ros_depends[@]})
# Tarball version (faster download)
_dir="qt_gui_core-release-release-indigo-qt_gui_cpp-${pkgver}-${_pkgver_patch}"
source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/qt_gui_core-release/archive/release/indigo/qt_gui_cpp/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('353d603d69c43457bbd9950b4d5b91f097b1772d8d3dddf2509af97d4f30fc46')
+sha256sums=('24d14352555852956c3581df5fda5c8dbb427577e46e23fc0e6d145955ec8e3b')
build() {
# Use ROS environment variables
@@ -46,6 +46,8 @@ build() {
# Fix Python2/Python3 conflicts
/usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ sed -ie 's/<QWidget>/<QtGui>/g' ${srcdir}/${_dir}/include/qt_gui_cpp/plugin_context.h
+
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
@@ -56,7 +58,9 @@ build() {
-DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
-DPYTHON_BASENAME=-python2.7 \
-DSETUPTOOLS_DEB_LAYOUT=OFF
+
make
+
}
package() {