summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9690de31a3a3..a6107ffaf4a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,14 @@ url='http://ros.org/wiki/rocon_python_utils'
pkgname='ros-indigo-rocon-python-utils'
pkgver='0.1.23'
-_pkgver_patch=0
+_pkgver_patch=1
arch=('any')
-pkgrel=1
+pkgrel=2
license=('BSD')
ros_makedepends=(ros-indigo-rostest
ros-indigo-catkin)
-makedepends=('cmake' 'git' 'ros-build-tools'
+makedepends=('cmake' 'ros-build-tools'
${ros_makedepends[@]}
python2-catkin-pkg)
@@ -23,10 +23,16 @@ depends=(${ros_depends[@]}
python2-catkin-pkg
python2-rospkg)
-_tag=release/indigo/rocon_python_utils/${pkgver}-${_pkgver_patch}
-_dir=rocon_python_utils
-source=("${_dir}"::"git+https://github.com/yujinrobot-release/rocon_tools-release.git"#tag=${_tag})
-md5sums=('SKIP')
+# Git version (e.g. for debugging)
+# _tag=release/indigo/rocon_python_utils/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/yujinrobot-release/rocon_tools-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="rocon_tools-release-release-indigo-rocon_python_utils-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/yujinrobot-release/rocon_tools-release/archive/release/indigo/rocon_python_utils/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('af8416b170f4b8b56a43a0863c2730944b562ba0ca0ab83dba0c3308949c831f')
build() {
# Use ROS environment variables