summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a754172b7d3..6001b1d0a789 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,11 +31,15 @@ ros_depends=(ros-jade-std-srvs
ros-jade-ros
ros-jade-genlisp
ros-jade-ros-comm
- ros-jade-roslisp
ros-jade-message-runtime
ros-jade-rosbag-migration-rule)
depends=(${ros_depends[@]})
+# roslisp cannot be installed on ARM
+if test "$CARCH" == x86_64 || test "$CARCH" == i686 ; then
+ ros_depends+=('ros-jade-roslisp')
+fi
+
_tag=release/jade/ros_core/${pkgver}-${_pkgver_patch}
_dir=ros_core
source=("${_dir}"::"git+https://github.com/ros-gbp/metapackages-release.git"#tag=${_tag})