summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD79
1 files changed, 79 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff4560480cd9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,79 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - OpenCV 3.x."
+url='http://opencvg.org'
+
+pkgname='ros-kinetic-opencv3'
+pkgver='3.1.0'
+_pkgver_patch=18
+arch=('any')
+pkgrel=19
+license=('BSD')
+
+ros_makedepends=()
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ python2-numpy
+ ffmpeg
+ libtiff
+ libjpeg-turbo
+ vtk
+ zlib
+ v4l-utils
+ jasper
+ protobuf
+ libpng
+ python2)
+
+ros_depends=(ros-kinetic-catkin)
+depends=(${ros_depends[@]}
+ python2-numpy
+ protobuf
+ libjpeg-turbo
+ vtk
+ zlib
+ jasper
+ ffmpeg
+ libpng
+ python2)
+
+# Git version (e.g. for debugging)
+# _tag=release/kinetic/opencv3/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/opencv3-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="opencv3-release-release-kinetic-opencv3-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/opencv3-release/archive/release/kinetic/opencv3/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('433174200f82e09fdcdce4d2779eb850b0bfd28bd85be9a7bbbbfda3e9afa2f9')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/kinetic/setup.bash ] && source /opt/ros/kinetic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}