summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD60
1 files changed, 60 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c623c1020cba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - This encapsulates the GL dependency for a specific ROS distribution and its Qt version."
+url='http://www.ros.org/'
+
+pkgname='ros-lunar-gl-dependency'
+pkgver='1.1.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-lunar-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=()
+depends=(${ros_depends[@]}
+ python2-pyqt5)
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/gl_dependency/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/gl_dependency-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="gl_dependency-release-release-lunar-gl_dependency-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/gl_dependency-release/archive/release/lunar/gl_dependency/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('0c78dcf34e3c49635238b3bec4becaa4d1ddc2469d90adab63929373f6a50428')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}