summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 47c71e0b9008..2d4002dc2af3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@ url='https://www.wiki.ros.org/catkin'
pkgname='ros-melodic-catkin'
pkgver='0.7.29'
-epoch=1
+epoch='1'
arch=('any')
-pkgrel=3
+pkgrel='2'
license=('BSD')
ros_makedepends=(
@@ -30,7 +30,7 @@ depends=(
python-empy
gmock
python
- ros-build-tools-py3
+ ros-build-tools
)
_dir="catkin-${pkgver}/"
@@ -53,9 +53,6 @@ build() {
[ -d ${srcdir}/build ] || mkdir ${srcdir}/build
cd ${srcdir}/build
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
-
# Build the project.
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \