summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 8 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4fd5356c6e18..6ca2de3791ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@ pkgdesc="ROS - Components of MoveIt that offer simpler interfaces to planning an
url='https://moveit.ros.org'
pkgname='ros-melodic-moveit-ros-planning-interface'
-pkgver='1.0.2'
-arch=('any')
-pkgrel=2
+pkgver='1.0.8'
+arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
+pkgrel=1
license=('BSD')
ros_makedepends=(ros-melodic-tf-conversions
@@ -50,15 +50,10 @@ depends=(${ros_depends[@]}
# Tarball version (faster download)
_dir="moveit-${pkgver}/moveit_ros/planning_interface"
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-planning/moveit/archive/${pkgver}.tar.gz"
- "eigenpy.patch")
-sha256sums=('b8194308c57dbe34bbb729cfccb30d1113af3a54a90a2cfb49482142d1044ea4'
- '797e2415ec9c66b2f7137bb6c0037e4f0ef5520baba7eff3af3eb04119e42b40')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-planning/moveit/archive/${pkgver}.tar.gz")
+sha256sums=('9f94cac094e0cd73caf2fb75ff85870045239806852aa00f6122f4785da23c14')
prepare() {
- cd ${srcdir}/${_dir}
- patch -uN CMakeLists.txt ${srcdir}/eigenpy.patch || return 1
-
cd ${srcdir}
find . \( -iname *.cpp -o -iname *.h \) \
-exec sed -r -i "s/[^_]logError/CONSOLE_BRIDGE_logError/" {} \; \
@@ -86,10 +81,9 @@ build() {
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.8 \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.8.so \
- -DPYTHON_BASENAME=.cpython-38 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+ -DBOOST_ROOT=/opt/boost1.69 \
+ -DBoost_NO_SYSTEM_PATHS=TRUE
make
}