summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 5 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0f607f41e1f6..d32d05629060 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,10 @@
-# Script generated with import_catkin_packages.py.
-# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - roscpp is a C++ implementation of ROS."
url='https://github.com/ros/ros_comm'
pkgname='ros-melodic-roscpp'
pkgver='1.14.10'
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
-pkgrel=2
+pkgrel=4
license=('BSD')
ros_makedepends=(
@@ -51,14 +49,11 @@ conflicts=(
)
_dir="ros_comm-${pkgver}/clients/roscpp"
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros/ros_comm/archive/${pkgver}.tar.gz"
- "boost_fixes.patch")
-sha256sums=('b3b75612feb447afe70600e3ba80bf3e356493a058ba8ebf2746e8db0c55165c'
- 'cf619e6a9082dc0f4d10f01ec773043f1803352b50de58e493534f43c6e063e5')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros/ros_comm/archive/${pkgver}.tar.gz")
+sha256sums=('b3b75612feb447afe70600e3ba80bf3e356493a058ba8ebf2746e8db0c55165c')
prepare() {
cd "${srcdir}/${_dir}"
- patch -p0 < ${srcdir}/boost_fixes.patch || return 1
}
@@ -74,16 +69,14 @@ build() {
# Fix Python2/Python3 conflicts.
/usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- #Workaround for boost signals
- sed -i 's/signals//g' ${srcdir}/${_dir}/CMakeLists.txt
-
# Build the project.
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+ -DBOOST_ROOT=/opt/boost1.69
make
}