summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 418e50858a4e..2c4534954863 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,12 @@
# Script generated with import_catkin_packages.py.
# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - This contains CvBridge, which converts between ROS Image messages and OpenCV images."
-url='https://www.wiki.ros.org/cv_bridge'
+url='https://wiki.ros.org/cv_bridge'
pkgname='ros-melodic-cv-bridge'
pkgver='1.13.0'
-_pkgver_patch=0
arch=('any')
-pkgrel=2
+pkgrel=3
license=('BSD')
ros_makedepends=(
@@ -41,13 +40,16 @@ depends=(
_dir="vision_opencv-${pkgver}/cv_bridge"
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-perception/vision_opencv/archive/${pkgver}.tar.gz"
- "endian-fix.patch")
+ "endian-fix.patch"
+ "boost-fix.patch")
sha256sums=('c8db35dbb6b470cdedb45195f725bc2cfda7f0dc3155e16a5a37e4b48e29fa59'
- 'bc06dbe12f26015c6bce73b2c95123851415d5662c17ef87267737dd433bb22b')
+ 'bc06dbe12f26015c6bce73b2c95123851415d5662c17ef87267737dd433bb22b'
+ '50658e5e213df03fa68c51bb399f541699cd022dac4ca68cfcdc19561bcea087')
prepare() {
cd "${srcdir}/${_dir}"
patch -uN src/module.hpp ../../../endian-fix.patch || return 1
+ patch -uN CMakeLists.txt ../../../boost-fix.patch || return 1
}
build() {