summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3f7a09817d12..ae57a91164f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,8 +37,16 @@ depends=(
)
_dir="qt_gui_core-${pkgver}/qt_gui_cpp"
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-visualization/qt_gui_core/archive/${pkgver}.tar.gz")
-sha256sums=('fbc5a7b0a4da43f80e9216845aec2e247fac0a63512053c03a9f89024d026aad')
+source=(
+ "${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-visualization/qt_gui_core/archive/${pkgver}.tar.gz"
+ "upstream.patch"::"https://github.com/ros-visualization/qt_gui_core/compare/0.4.2...melodic-devel.patch"
+)
+sha256sums=('fbc5a7b0a4da43f80e9216845aec2e247fac0a63512053c03a9f89024d026aad' 'SKIP')
+
+prepare() {
+ cd ${srcdir}/qt_gui-core-${pkgver}
+ patch -Np1 -i ${srcdir}/upstream.patch
+}
build() {
# Use ROS environment variables.