summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e46cc90e5fa5..985e68e6ba63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -38,9 +38,19 @@ depends=(
python-rospkg
)
-_dir="rqt_tf_tree-${pkgver}/"
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-visualization/rqt_tf_tree/archive/${pkgver}.tar.gz")
-sha256sums=('2167fefc172a02d9ae829e96a8dd3280a41c125d3f8840134247f60dd9f6d505')
+_dir="rqt_tf_tree-${pkgver}"
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-visualization/rqt_tf_tree/archive/${pkgver}.tar.gz"
+ "https://github.com/ros-visualization/rqt_tf_tree/pull/28.patch"
+ "https://github.com/ros-visualization/rqt_tf_tree/pull/30.patch")
+sha256sums=('0d5996679310b747ac49d52c39e7869870458065b8ba118ed48b105d9f252604'
+ 'SKIP'
+ 'SKIP')
+
+prepare() {
+ cd "$srcdir/$_dir"
+ patch --forward --strip=1 --input="${srcdir}/28.patch"
+ patch --forward --strip=1 --input="${srcdir}/30.patch"
+}
build() {
# Use ROS environment variables.