summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD149
1 files changed, 71 insertions, 78 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7a1c39e3e048..4ddd38721031 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: dangerdev <dangerdev004@protonmail.com>
+# Contributor: dangerdev <dangerdev004@protonmail.com>
# Contributor: leuko <aur_202302 at aydos.de>
# Contributor: Tobias Borgert <tobias.borgert@gmail.com>
# Contributor: kartikmohta
@@ -6,86 +6,79 @@
pkgname=ros2-arch-deps
pkgver=0.17
pkgrel=1
-pkgdesc="Dependencies for building ROS2 on Arch"
+pkgdesc="[Meta-PKG] Dependencies for building ROS2 on Arch"
url="https://index.ros.org/doc/ros2/"
arch=('any')
license=('none')
-depends=('asio'
- 'bullet'
- 'cmake'
- 'eigen'
- 'git'
- 'glew'
- 'glu'
- 'hdf5'
- 'libxaw'
- 'libxrandr'
- 'log4cxx'
- 'opencv'
- 'poco'
- 'python'
- 'python-cryptography'
- 'python-empy'
- 'python-lark-parser'
- 'python-netifaces'
- 'python-nose'
- 'python-notify2'
- 'python-numpy'
- 'python-pyqt5'
- 'python-pytest-repeat'
- 'python-setuptools'
- 'python-yaml'
- 'procps-ng' # provides /usr/bin/free command
- 'qt5-base'
- 'qt5-svg'
- 'tinyxml'
- 'tinyxml2'
- 'vtk'
- 'wget'
- # AUR
- 'python-vcstool'
- 'python-colcon-argcomplete'
- 'python-colcon-bash'
- 'python-catkin_pkg'
- 'python-colcon-cmake'
- 'python-colcon-core'
- 'python-colcon-defaults'
- 'python-colcon-devtools'
- 'python-colcon-library-path'
- 'python-colcon-metadata'
- 'python-colcon-notification'
- 'python-colcon-output'
- 'python-colcon-package-information'
- 'python-colcon-package-selection'
- 'python-colcon-pkg-config'
- 'python-colcon-parallel-executor'
- 'python-colcon-powershell'
- 'python-colcon-python-setup-py'
- 'python-colcon-recursive-crawl'
- 'python-colcon-ros'
- 'python-colcon-test-result'
- 'python-colcon-zsh'
- 'python-colcon-cd'
- 'python-colcon-common-extensions'
- 'python-pyqt5-sip4'
- 'python-rospkg'
- 'python-rosdistro'
- 'python-rosdep'
- 'python-sip4'
- 'sip4'
+depends=(
+ 'asio'
+ 'bullet'
+ 'cmake'
+ 'eigen'
+ 'git'
+ 'glew'
+ 'glu'
+ 'hdf5'
+ 'libxaw'
+ 'libxrandr'
+ 'log4cxx'
+ 'opencv'
+ 'poco'
+ 'procps-ng' # provides /usr/bin/free command
+ 'python'
+ 'python-cryptography'
+ 'python-empy'
+ 'python-lark-parser'
+ 'python-netifaces'
+ 'python-nose'
+ 'python-notify2'
+ 'python-numpy'
+ 'python-pyqt5'
+ 'python-pytest-repeat'
+ 'python-setuptools'
+ 'python-yaml'
+ 'qt5-base'
+ 'qt5-svg'
+ 'tinyxml'
+ 'tinyxml2'
+ 'vtk'
+ 'wget'
+ # AUR
+ 'python-catkin_pkg'
+ 'python-colcon-argcomplete'
+ 'python-colcon-bash'
+ 'python-colcon-cd'
+ 'python-colcon-cmake'
+ 'python-colcon-common-extensions'
+ 'python-colcon-core'
+ 'python-colcon-defaults'
+ 'python-colcon-devtools'
+ 'python-colcon-library-path'
+ 'python-colcon-metadata'
+ 'python-colcon-notification'
+ 'python-colcon-output'
+ 'python-colcon-package-information'
+ 'python-colcon-package-selection'
+ 'python-colcon-parallel-executor'
+ 'python-colcon-pkg-config'
+ 'python-colcon-powershell'
+ 'python-colcon-python-setup-py'
+ 'python-colcon-recursive-crawl'
+ 'python-colcon-ros'
+ 'python-colcon-test-result'
+ 'python-colcon-zsh'
+ 'python-pyqt5-sip4'
+ 'python-rosdep'
+ 'python-rosdistro'
+ 'python-rospkg'
+ 'python-sip4'
+ 'python-vcstool'
+ 'sip4'
)
-optdepends=('python-pydot: running the node graph in rqt'
- 'python-pyqtgraph: for plotting in rqt'
- 'python-matplotlib: for plotting in rqt')
-
-md5sums=()
-
-build() {
- :
-}
-
-package() {
- :
-}
+optdepends=(
+ 'python-matplotlib: for plotting in rqt'
+ 'python-pydot: running the node graph in rqt'
+ 'python-pyqtgraph: for plotting in rqt'
+)