summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60fc4d384ee7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+
+_pkgname=gazebo_msgs
+pkgname=ros2-humble-gazebo-msgs
+pkgver=3.7.0
+pkgrel=1
+pkgdesc="Message and service data structures for interacting with Gazebo from ROS"
+url="https://index.ros.org/p/gazebo_msgs/"
+arch=('any')
+depends=(
+ 'ros2-humble'
+)
+source=("https://github.com/ros-simulation/gazebo_ros_pkgs/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('69093e3cc7c4194f958bff777e76ab7c9a8f5c880f764332eb961f791a5a73a4')
+
+prepare() {
+ source /opt/ros/humble/setup.bash
+
+ cmake -S gazebo_ros_pkgs-$pkgver/$_pkgname -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
+}
+
+build() {
+ make -C build
+}
+
+package() {
+ make DESTDIR="$pkgdir/" -C build install
+}