summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 67e8d79ef552..f398332b65a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,33 @@
# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+_pkgroot=cpp_polyfills
_pkgname=tl_expected
pkgname=ros2-humble-tl-expected
pkgver=1.0.2
-pkgrel=2
+pkgrel=3
pkgdesc="C++11/14/17 std::expected with functional-style extensions"
url="https://index.ros.org/p/tl_expected/"
arch=('any')
depends=(
'ros2-humble'
)
+makedepends=('cmake')
source=("https://github.com/PickNikRobotics/cpp_polyfills/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('b7dde11bd51f5a7ded145fbc9a66b5ec304063117da73e19212757cb39830c21')
prepare() {
source /opt/ros/humble/setup.bash
-
- cmake -S cpp_polyfills-$pkgver/$_pkgname -B build \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
}
build() {
-source /opt/ros/humble/setup.bash
- make -C build
+ cmake -B build -S "$_pkgroot-$pkgver/$_pkgname" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/opt/ros/humble' \
+ -Wno-dev
+
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir/" -C build install
+ DESTDIR="$pkgdir" cmake --install build
}