summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 29 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9abe32d993fc..1f84081e86dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,48 @@
-# Maintainer: David Roheim <david.roheim@gmail.com>
-# Contributer: Thomas Dziedzic < gostrc at gmail >
+# Contributor: David Roheim <david.roheim@gmail.com>
+# Contributor: Thomas Dziedzic < gostrc at gmail >
pkgname=rpmlint
pkgver=1.6
pkgrel=1
pkgdesc='A tool for checking common errors in rpm packages.'
arch=('any')
-url=("http://${pkgname}.sourceforge.net/")
-license=('GPL')
-depends=('python2>=2.6' 'rpm-org' 'cpio' 'desktop-file-utils')
-source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}-${pkgver}.tar.xz")
+url="http://$pkgname.sourceforge.net/"
+license=('GPL2')
+depends=('cpio' 'desktop-file-utils' 'python2>=2.6' 'rpm-org')
+makedepends=('bash-completion')
+checkdepends=('python2-pytest')
+source=("http://downloads.sourceforge.net/project/$pkgname/$pkgname-$pkgver.tar.xz")
sha256sums=('a0dae71a3fed413ee5c47bd04f393cd6598c68c0dcf1504fa020d62814ff674b')
prepare() {
- cd "${pkgname}-${pkgver}"
+ cd "$pkgname-$pkgver"
- for file in "${pkgname}" rpmdiff tools/generate-isocodes.py; do
- sed -e 's_/usr/bin/python_&2_' -i "${file}"
- done
+ for file in "$pkgname" rpmdiff tools/generate-isocodes.py; do
+ sed -e 's_/usr/bin/python_&2_' -i "$file"
+ done
+
+ sed -e 's_py\.test_&2_' -i test.sh
}
build() {
- cd "${pkgname}-${pkgver}"
+ cd "$pkgname-$pkgver"
- make PYTHON=python2 COMPILE_PYC=1
+ make PYTHON=python2 COMPILE_PYC=1
}
+# Tests need a non-empty RPM database on the system
+# It may be created using "rpm --initdb"
+#check() {
+# cd "$pkgname-$pkgver"
+# make check
+#}
+
package() {
- cd "${pkgname}-${pkgver}"
+ cd "$pkgname-$pkgver"
- make PYTHON=python2 DESTDIR="${pkgdir}" install
+ make PYTHON=python2 DESTDIR="$pkgdir/" install
+
+ install -Dp -m644 README "$pkgdir/usr/share/doc/$pkgname/README"
}
+
+# vim: set ft=sh ts=4 sw=4 noet: