summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 937a8947a9aa..d5e76a2f5f72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=rr
pkgver=4.5.0
-pkgrel=1
+pkgrel=2
pkgdesc='Record and Replay framework: lightweight recording and deterministic debugging'
arch=(i686 x86_64)
url='http://rr-project.org/'
@@ -11,12 +11,17 @@ license=('custom')
depends=('python2-pexpect' 'gdb')
makedepends=('git' 'cmake' 'gdb')
[ "$CARCH" = 'x86_64' ] && makedepends+=('gcc-multilib')
-source=(https://github.com/mozilla/${pkgname}/archive/${pkgver}.tar.gz)
-sha1sums=('70d3902c36fb1d0cd423cf1046df06f5153cba5b')
+source=(https://github.com/mozilla/${pkgname}/archive/${pkgver}.tar.gz
+ https://patch-diff.githubusercontent.com/raw/mozilla/rr/pull/2001.patch)
+sha1sums=('70d3902c36fb1d0cd423cf1046df06f5153cba5b'
+ '51dba5dbbe16c3631a101409a28247075668fe7b')
prepare() {
cd $pkgname-$pkgver
mkdir -p build
+
+ # -Werror fixes
+ patch -p1 -i ../2001.patch
}
build() {