summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 023a46cdfe27..d8ea66440913 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=rr
pkgver=5.4.0
-pkgrel=5
+pkgrel=6
pkgdesc='Record and Replay framework: lightweight recording and deterministic debugging'
arch=(i686 x86_64)
url='http://rr-project.org/'
@@ -15,11 +15,14 @@ options=(!strip)
source=(
$pkgname-$pkgver.tar.gz::https://github.com/rr-debugger/${pkgname}/archive/${pkgver}.tar.gz
+ https://patch-diff.githubusercontent.com/raw/rr-debugger/rr/pull/2726.diff
)
-sha1sums=('b4716dd10b01ae4b8d35ae08f4f67fc46f0693d9')
+sha1sums=('b4716dd10b01ae4b8d35ae08f4f67fc46f0693d9'
+ '80abae19e4486df97e922dcc7a906b96a1e00bc3')
prepare() {
cd $pkgname-$pkgver
+ patch -Np1 -i $srcdir/2726.patch
mkdir -p build
}