summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 36f50fc658ba..236b17271a87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Atle Solbakken <atle@goliathdns.no>
pkgname="rrr"
-pkgver=1.25.1
+pkgver=1.29.2
pkgrel=0
pkgdesc="Read Route Record is a messaging daemon supporting HTTP, MQTT, TCP, UDP +++"
arch=('i686' 'arm64' 'x86_64' 'aarch64')
url="https://www.github.com/atlesn/rrr"
license=('GPL')
-depends=('python3' 'perl' 'mariadb-clients' 'libnghttp2' 'json-c' 'libevent' 'jemalloc')
-optdepends=('systemd: systemd daemon support')
+depends=('python3' 'perl' 'mariadb-clients' 'libnghttp2' 'json-c' 'libevent' 'jemalloc' 'lua' 'v8-r')
+optdepends=('systemd: systemd daemon support' 'libbsd: set process titles')
makedepends=('git')
provides=('rrr')
-source=("git+https://github.com/atlesn/$pkgname.git#tag=v1.25-1")
+source=("git+https://github.com/atlesn/$pkgname.git#tag=v1.29-2")
md5sums=('SKIP')
pkgver() {
@@ -25,7 +25,7 @@ prepare() {
build() {
cd "${srcdir}/${pkgname}"
autoreconf -i
- ./configure --prefix=/usr --sysconfdir=/etc
+ ./configure --prefix=/usr --sysconfdir=/etc --with-v8 --enable-v8-sandbox
make
}