summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a824a626eba..d3c649c3f523 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
# Maintainer: Jannik Becher <becher.jannik@gmail.com>
pkgname=rshell
-pkgver=0.0.24
+_name=${pkgname#python-}
+provides=(rshell)
+conflicts=(rshell)
+pkgver=0.0.26
pkgrel=1
pkgdesc="A remote shell for working with MicroPython boards."
url="https://github.com/dhylands/rshell"
-depends=('python' 'python-pyudev' 'python-pyserial')
-makedepends=('python3')
+depends=('python-pyudev' 'python-pyserial')
+makedepends=('python-setuptools')
license=('MIT')
arch=('any')
-source=('https://files.pythonhosted.org/packages/5e/70/d48ce2329734b214d81b08b7ba048869eefafac9d5b482dbccd4f7a4dbef/rshell-0.0.24.tar.gz')
-md5sums=('6fc1bda8781d1ca77a0d1e37b58620ef')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('cc447a3c9853a50585d7fdd6356922e8a89debb67932e60cf241f23fbd72db16')
build() {
- cd $srcdir/rshell-0.0.24
+ cd $srcdir/${_name}-${pkgver}
python setup.py build
}
package() {
- cd $srcdir/rshell-0.0.24
- python setup.py install --root="$pkgdir" --optimize=1
+ cd $srcdir/${_name}-${pkgver}
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}