summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af46db1ebde8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=rtile-git
+pkgver=1
+pkgrel=1
+pkgdesc="Ruby script for manual tiling and window placement."
+arch=('i686' 'x86_64' 'armv7h')
+url="https://github.com/xhsdf/rtile"
+license=('GPL')
+depends=('ruby' 'xorg-xprop' 'wmctrl' 'xorg-xrandr')
+makedepends=('git')
+conflicts=('rtile')
+provides=('rtile')
+# The git repo is detected by the 'git:' or 'git+' beginning. The branch
+# '$pkgname' is then checked out upon cloning, expediating versioning:
+#source=('git+https://github.com/falconindy/expac.git'
+source=("$pkgname"::'git://github.com/xhsdf/rtile.git')
+# Because the sources are not static, skip Git checksum:
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ # Use the tag of the last commit
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 "rtile.rb" "$pkgdir/usr/bin/rtile"
+}