summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e1645cbcba07..dec8d769b4ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,19 +7,21 @@ _dver="${pkgver}.20191028_COEX20190531-0e0e"
pkgrel=4
pkgdesc="Realtek RTL88x2CE Driver (DKMS)"
arch=('x86_64' 'i686')
-url="https://github.com/alanfox2000/realtek-linux/blob/master/RTL8822CE"
-license=('unknown')
+url="https://github.com/XAIOThaifeng/realtek-linux/blob/master/RTL8822CE"
+license=('GPL')
depends=('dkms' 'bc')
optdepends=('linux-headers' 'linux-zen-headers')
provides=('rtl88x2ce')
source=(
- "$pkgname-$pkgver.src.7z::https://github.com/alanfox2000/realtek-linux/blob/master/RTL8822CE/RTL8822CE_WiFi_linux_v$_allver.7z?raw=true"
+ "$pkgname-$pkgver.src.7z::https://github.com/XAIOThaifeng/realtek-linux/blob/master/RTL8822CE/RTL8822CE_WiFi_linux_v$_allver.7z?raw=true"
dkms.conf
rtw88_blacklist.conf
+ linux58.patch
)
sha1sums=('a798b10d4f2c962c246f2c1bc695314e2b15e7b3'
- '7aa512c830c044506581158cca931da411017ad0'
- '18ecc64076501d396a2fabf4f1f31d3d1945b874')
+ '1f8eb72a676c311a434ccece3f2bad2c20ddaa09'
+ 'cff1484236d2bdaf0d1e10a1b789950e9ff3d3da'
+ 'c2ff3cb66952337ec8b37ebaebad5e4c017fb4c2')
prepare() {
cd "$srcdir/RTL8822CE_WiFi_linux_v$_allver/driver"
@@ -38,6 +40,8 @@ prepare() {
# Disable debug
sed -i '/^CONFIG_RTW_DEBUG/c\CONFIG_RTW_DEBUG = n' Makefile
+
+ patch -p 1 -i "$srcdir/linux58.patch"
}
package() {