summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 7 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3791099cd539..fcb7644a6559 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,25 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
+# Maintainer: Marcel Röthke <marce.roethke@haw-hamburg.de>
-# Maintainer: Marcel Röthke <marcel@roethke.info>
pkgname=rtrlib
pkgver=0.3.6
-pkgrel=1
+pkgrel=2
pkgdesc="RPKI-RTR client library"
-arch=(x86_64)
-url=""https://github.com/rtrlib/rtrlib
+arch=(x86_64 i686)
+url="https://github.com/rtrlib/rtrlib"
license=('MIT')
-depends=()
+depends=(libssh)
makedepends=(cmake)
options=(strip)
source=("rtrlib-$pkgver.tar.gz::https://github.com/rtrlib/rtrlib/archive/v$pkgver.tar.gz")
-#https://github.com/rtrlib/rtrlib/archive/v0.3.6.tar.gz
md5sums=(07912a1612b1e949f16e0f1c6474392c)
build() {
cd ${srcdir}/${pkgname}-${pkgver}
- echo $pkgname-$pkgver
cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR:STRING=lib \
- .
+ .
+
make rtrlib
}